What’s Vulnerable › Vulnerabilities
CVE-2023-51784: Apache InLong: Remote Code Execution vulnerability in Apache InLong Manager
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.This issue affects Apache InLong: from 1.5.0 through 1.9.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.10.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9329
Affected products
- Apache Software Foundation Apache InLong: from 1.5.0 before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache InLong 1.10.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/03/1
- https://lists.apache.org/thread/4nxbyl6mh5jgh0plk0qposbxwn6w9h8j
- http://www.openwall.com/lists/oss-security/2024/01/03/1
- https://lists.apache.org/thread/4nxbyl6mh5jgh0plk0qposbxwn6w9h8j
Get alerted when CVE-2023-51784 or the next vulnerability affects your stack