What’s Vulnerable › Vulnerabilities
CVE-2023-5183: Authenticated RCE due to unsafe JSON deserialization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-502
Description
Unsafe deserialization of untrusted JSON allows execution of arbitrary code on affected releases of the Illumio PCE. Authentication to the API is required to exploit this vulnerability. The flaw exists within the network_traffic API endpoint. An attacker can leverage this vulnerability to execute code in the context of the PCE’s operating system user.
Affected products
- Illumio Core PCE: before 19.3.7; from 21.2.0 before 21.2.8; from 21.5.0 before 21.5.36; from 22.2.0 before 22.2.42; from 22.5.0 before 22.5.31; from 23.2.0 before 23.2.11 — fixed in 19.3.7, 21.2.8, 21.5.36, 22.2.42, 22.5.31, 23.2.11
How to fix
Upgrade to a fixed version: Illumio Core PCE 19.3.7, 21.2.8, 21.5.36, 22.2.42. Check the vendor advisory for mitigations.
References
- https://docs.illumio.com/Guides/security-advisories/september-2023/cve-2023-5183.htm
- https://docs.illumio.com/Guides/security-advisories/september-2023/cve-2023-5183.htm
Get alerted when CVE-2023-5183 or the next vulnerability affects your stack