What’s Vulnerable › Vulnerabilities
CVE-2023-5188: WAGO Improper Input Validation in IEC61850 Server / Telecontrol
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-05 · updated 2026-06-17
- Weakness: CWE-20
Description
The MMS Interpreter of WagoAppRTU in versions below 1.4.6.0 which is used by the WAGO Telecontrol Configurator is vulnerable to malformed packets. An remote unauthenticated attacker could send specifically crafted packets that lead to a denial-of-service condition until restart of the affected device.
Affected products
- WAGO Telecontrol Configurator: all versions
- WagoAppRTU: before 1.4.6.0 — fixed in 1.4.6.0
How to fix
Upgrade to a fixed version: WagoAppRTU 1.4.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-5188 or the next vulnerability affects your stack