What’s Vulnerable › Vulnerabilities
CVE-2023-5207: Execution with Unnecessary Privileges in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-30 · updated 2026-06-17
- Weakness: CWE-250
Description
A vulnerability was discovered in GitLab CE and EE affecting all versions starting 16.0 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. An authenticated attacker could perform arbitrary pipeline execution under the context of another user.
Affected products
- GitLab: from 16.0.0 before 16.2.8; from 16.3.0 before 16.3.5; 16.4.0 — fixed in 16.2.8, 16.3.5
How to fix
Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/425604
- https://gitlab.com/gitlab-org/gitlab/-/issues/425857
- https://hackerone.com/reports/2174141
- https://gitlab.com/gitlab-org/gitlab/-/issues/425604
- https://gitlab.com/gitlab-org/gitlab/-/issues/425857
- https://hackerone.com/reports/2174141
Get alerted when CVE-2023-5207 or the next vulnerability affects your stack