What’s Vulnerable › Vulnerabilities
CVE-2023-52081: ewen-lbh/ffcss late-Unicode normalization vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-28 · updated 2026-06-17
- Weakness: CWE-74
Description
ffcss is a CLI interface to apply and configure Firefox CSS themes. Prior to 0.2.0, the function `lookupPreprocess()` is meant to apply some transformations to a string by disabling characters in the regex `[-_ .]`. However, due to the use of late Unicode normalization of type NFKD, it is possible to bypass that validation and re-introduce all the characters in the regex `[-_ .]`. The `lookupPreprocess()` can be easily bypassed with equivalent Unicode characters like U+FE4D (﹍), which would result in the omitted U+005F (_), for instance. The `lookupPreprocess()` function is only ever used to search for themes loosely (case insensitively, while ignoring dashes, underscores and dots), so the actual security impact is classified as low. This vulnerability is fixed in 0.2.0. There are no known workarounds.
Affected products
- ewen-lbh Firefox Css: before 0.2.0 — fixed in 0.2.0
How to fix
Upgrade to a fixed version: ewen-lbh Firefox Css 0.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/ewen-lbh/ffcss/commit/f9c491874b858a32fcae15045f169fd7d02f90dc
- https://github.com/ewen-lbh/ffcss/security/advisories/GHSA-wpmx-564x-h2mh
- https://github.com/ewen-lbh/ffcss/commit/f9c491874b858a32fcae15045f169fd7d02f90dc
- https://github.com/ewen-lbh/ffcss/security/advisories/GHSA-wpmx-564x-h2mh
Get alerted when CVE-2023-52081 or the next vulnerability affects your stack