What’s Vulnerable › Vulnerabilities
CVE-2023-5214: CVE-2023-5214 - Privilege Escalation in Puppet Bolt
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-06 · updated 2026-06-17
- Weakness: CWE-269
Description
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
Affected products
- Puppet Bolt: before 3.27.4 — fixed in 3.27.4
How to fix
Upgrade to a fixed version: Puppet Bolt 3.27.4. Check the vendor advisory for mitigations.
References
- https://www.puppet.com/security/cve/cve-2023-5214-privilege-escalation-puppet-bolt
- https://www.puppet.com/security/cve/cve-2023-5214-privilege-escalation-puppet-bolt
Get alerted when CVE-2023-5214 or the next vulnerability affects your stack