What’s Vulnerable › Vulnerabilities
CVE-2023-52159
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
Affected products
- Bizdelnick Gross: from 0.9.3 before 1.0.4 — fixed in 1.0.4
- Debian Linux: 10.0
How to fix
Upgrade to a fixed version: Bizdelnick Gross 1.0.4. Check the vendor advisory for mitigations.
References
- https://codeberg.org/bizdelnick/gross/wiki/Known-vulnerabilities#cve-2023-52159
- https://lists.debian.org/debian-lts-announce/2024/03/msg00027.html
- https://codeberg.org/bizdelnick/gross/wiki/Known-vulnerabilities#cve-2023-52159
- https://lists.debian.org/debian-lts-announce/2024/03/msg00027.html
Get alerted when CVE-2023-52159 or the next vulnerability affects your stack