What’s Vulnerable › Vulnerabilities
CVE-2023-5228: User Registration < 3.0.4.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The User Registration WordPress plugin before 3.0.4.2 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- wpeverest User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Cu: before 3.0.4.2 — fixed in 3.0.4.2
How to fix
Upgrade to a fixed version: wpeverest User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Cu 3.0.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/50ae7008-46f0-4f89-ae98-65dcabe4ef09
- https://wpscan.com/vulnerability/50ae7008-46f0-4f89-ae98-65dcabe4ef09
Get alerted when CVE-2023-5228 or the next vulnerability affects your stack