What’s Vulnerable › Vulnerabilities
CVE-2023-5229: E2Pdf < 1.20.20 - Admin+ Stored Cross-Site Scriping
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The E2Pdf WordPress plugin before 1.20.20 does not sanitize and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- e2pdf: before 1.20.20 — fixed in 1.20.20
How to fix
Upgrade to a fixed version: e2pdf 1.20.20. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fb6ce636-9e0d-4c5c-bb95-dde1d2581245
- https://wpscan.com/vulnerability/fb6ce636-9e0d-4c5c-bb95-dde1d2581245
Get alerted when CVE-2023-5229 or the next vulnerability affects your stack