What’s Vulnerable › Vulnerabilities
CVE-2023-52307: Stack overflow in paddle.linalg.lu_unpack
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-120
Description
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
Affected products
- paddlepaddle/paddle: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: paddlepaddle/paddle 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-016.md
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-016.md
Get alerted when CVE-2023-52307 or the next vulnerability affects your stack