What’s Vulnerable › Vulnerabilities
CVE-2023-52323
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-05 · updated 2026-06-17
- Weakness: CWE-203
Description
PyCryptodome and pycryptodomex before 3.19.1 allow side-channel leakage for OAEP decryption, exploitable for a Manger attack.
Affected products
- Pycryptodome: before 3.19.1 — fixed in 3.19.1
- Pycryptodomex: before 3.19.1 — fixed in 3.19.1
How to fix
Upgrade to a fixed version: Pycryptodome 3.19.1; Pycryptodomex 3.19.1. Check the vendor advisory for mitigations.
References
- https://github.com/Legrandin/pycryptodome/blob/master/Changelog.rst
- https://pypi.org/project/pycryptodomex/#history
- https://github.com/Legrandin/pycryptodome/blob/master/Changelog.rst
- https://pypi.org/project/pycryptodomex/#history
Get alerted when CVE-2023-52323 or the next vulnerability affects your stack