What’s Vulnerable › Vulnerabilities
CVE-2023-52340
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-05 · updated 2026-06-17
- Weakness: CWE-400
Description
The IPv6 implementation in the Linux kernel before 6.3 has a net/ipv6/route.c max_size threshold that can be consumed easily, e.g., leading to a denial of service (network is unreachable errors) when IPv6 packets are sent in a loop via a raw socket.
Affected products
- Linux kernel: before 6.3 — fixed in 6.3
How to fix
Upgrade to a fixed version: Linux kernel 6.3. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.3
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=af6d10345ca76670c1b7c37799f0d5576ccef277
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.3
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=af6d10345ca76670c1b7c37799f0d5576ccef277
- https://lists.debian.org/debian-lts-announce/2024/06/msg00016.html
- https://lists.debian.org/debian-lts-announce/2024/06/msg00020.html
- https://security.netapp.com/advisory/ntap-20240816-0005/
Get alerted when CVE-2023-52340 or the next vulnerability affects your stack