What’s Vulnerable › Vulnerabilities
CVE-2023-5237: Memberlite Shortcodes < 1.3.9 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The Memberlite Shortcodes WordPress plugin before 1.3.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Affected products
- strangerstudios Memberlite Shortcodes: before 1.3.9 — fixed in 1.3.9
How to fix
Upgrade to a fixed version: strangerstudios Memberlite Shortcodes 1.3.9. Check the vendor advisory for mitigations.
References
- https://research.cleantalk.org/cve-2023-5237-memberlite-shortcodes-stored-xss-via-shortcode
- https://wpscan.com/vulnerability/a46d686c-6234-4aa8-a656-00a65c55d0b0
- https://research.cleantalk.org/cve-2023-5237-memberlite-shortcodes-stored-xss-via-shortcode
- https://wpscan.com/vulnerability/a46d686c-6234-4aa8-a656-00a65c55d0b0
Get alerted when CVE-2023-5237 or the next vulnerability affects your stack