What’s Vulnerable › Vulnerabilities
CVE-2023-52389
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-27 · updated 2026-06-17
- Weakness: CWE-190
Description
UTF32Encoding.cpp in POCO has a Poco::UTF32Encoding integer overflow and resultant stack buffer overflow because Poco::UTF32Encoding::convert() and Poco::UTF32::queryConvert() may return a negative integer if a UTF-32 byte sequence evaluates to a value of 0x80000000 or higher. This is fixed in 1.11.8p2, 1.12.5p2, and 1.13.0.
Affected products
- poco: before 1.11.8; from 1.12.0 before 1.12.5; 1.11.8, 1.11.8-p1, 1.12.5 — fixed in 1.11.8, 1.12.5
How to fix
Upgrade to a fixed version: poco 1.11.8, 1.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/pocoproject/poco/compare/poco-1.12.5p2-release...poco-1.13.0-release
- https://github.com/pocoproject/poco/issues/4320
- https://pocoproject.org/blog/?p=1226
- https://github.com/pocoproject/poco/compare/poco-1.12.5p2-release...poco-1.13.0-release
- https://github.com/pocoproject/poco/issues/4320
- https://lists.debian.org/debian-lts-announce/2025/01/msg00017.html
- https://pocoproject.org/blog/?p=1226
Get alerted when CVE-2023-52389 or the next vulnerability affects your stack