What’s Vulnerable › Vulnerabilities
CVE-2023-52440: ksmbd: fix slub overflow in ksmbd_decode_ntlmssp_auth_blob()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-08-15
- Weakness: CWE-119
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix slub overflow in ksmbd_decode_ntlmssp_auth_blob() If authblob->SessionKey.Length is bigger than session key size(CIFS_KEY_SIZE), slub overflow can happen in key exchange codes. cifs_arc4_crypt copy to session key array from SessionKey from client.
Affected products
- Linux kernel: from 5.17.0 before 6.1.52; from 6.2.0 before 6.4.15; from 6.5.0 before 6.5.2 — fixed in 6.1.52, 6.4.15, 6.5.2
How to fix
Upgrade to a fixed version: Linux kernel 6.1.52, 6.4.15, 6.5.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/30fd6521b2fbd9b767e438e31945e5ea3e3a2fba
- https://git.kernel.org/stable/c/4b081ce0d830b684fdf967abc3696d1261387254
- https://git.kernel.org/stable/c/7f1d6cb0eb6af3a8088dc24b7ddee9a9711538c4
- https://git.kernel.org/stable/c/bd554ed4fdc3d38404a1c43d428432577573e809
- https://git.kernel.org/stable/c/ecd7e1c562cb08e41957fcd4b0e404de5ab38e20
- https://git.kernel.org/stable/c/30fd6521b2fbd9b767e438e31945e5ea3e3a2fba
- https://git.kernel.org/stable/c/4b081ce0d830b684fdf967abc3696d1261387254
- https://git.kernel.org/stable/c/7f1d6cb0eb6af3a8088dc24b7ddee9a9711538c4
- https://git.kernel.org/stable/c/bd554ed4fdc3d38404a1c43d428432577573e809
- https://git.kernel.org/stable/c/ecd7e1c562cb08e41957fcd4b0e404de5ab38e20
Get alerted when CVE-2023-52440 or the next vulnerability affects your stack