What’s Vulnerable › Vulnerabilities
CVE-2023-52441: ksmbd: fix out of bounds in init_smb2_rsp_hdr()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-08-15
- Weakness: CWE-119
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix out of bounds in init_smb2_rsp_hdr() If client send smb2 negotiate request and then send smb1 negotiate request, init_smb2_rsp_hdr is called for smb1 negotiate request since need_neg is set to false. This patch ignore smb1 packets after ->need_neg is set to false.
Affected products
- Linux kernel: from 5.15.0 before 5.15.145; from 5.16.0 before 6.1.53; from 6.2.0 before 6.4.16 — fixed in 5.15.145, 6.1.53, 6.4.16
How to fix
Upgrade to a fixed version: Linux kernel 5.15.145, 6.1.53, 6.4.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/330d900620dfc9893011d725b3620cd2ee0bc2bc
- https://git.kernel.org/stable/c/536bb492d39bb6c080c92f31e8a55fe9934f452b
- https://git.kernel.org/stable/c/5c0df9d30c289d6b9d7d44e2a450de2f8e3cf40b
- https://git.kernel.org/stable/c/aa669ef229ae8dd779da9caa24e254964545895f
- https://git.kernel.org/stable/c/330d900620dfc9893011d725b3620cd2ee0bc2bc
- https://git.kernel.org/stable/c/536bb492d39bb6c080c92f31e8a55fe9934f452b
- https://git.kernel.org/stable/c/5c0df9d30c289d6b9d7d44e2a450de2f8e3cf40b
- https://git.kernel.org/stable/c/aa669ef229ae8dd779da9caa24e254964545895f
Get alerted when CVE-2023-52441 or the next vulnerability affects your stack