What’s Vulnerable › Vulnerabilities
CVE-2023-52507: nfc: nci: assert requested protocol is valid
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-02 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: nfc: nci: assert requested protocol is valid The protocol is used in a bit mask to determine if the protocol is supported. Assert the provided protocol is less than the maximum defined so it doesn't potentially perform a shift-out-of-bounds and provide a clearer error for undefined protocols vs unsupported ones.
Affected products
- Linux kernel: from 3.2 before 4.14.328; from 4.15 before 4.19.297; from 4.20 before 5.4.259; from 5.5 before 5.10.199; from 5.11 before 5.15.136; from 5.16 before 6.1.59 — fixed in 4.14.328, 4.19.297, 5.10.199, 5.15.136, 5.4.259, 6.1.59
How to fix
Upgrade to a fixed version: Linux kernel 4.14.328, 4.19.297, 5.10.199, 5.15.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/25dd54b95abfdca423b65a4ee620a774777d8213
- https://git.kernel.org/stable/c/2c231a247a1d1628e41fa1eefd1a5307c41c5f53
- https://git.kernel.org/stable/c/354a6e707e29cb0c007176ee5b8db8be7bd2dee0
- https://git.kernel.org/stable/c/6584eba7688dcf999542778b07f63828c21521da
- https://git.kernel.org/stable/c/853dda54ba59ea70d5580a298b7ede4707826848
- https://git.kernel.org/stable/c/95733ea130e35ef9ec5949a5908dde3feaba92cb
- https://git.kernel.org/stable/c/a424807d860ba816aaafc3064b46b456361c0802
- https://git.kernel.org/stable/c/a686f84101680b8442181a8846fbd3c934653729
- https://git.kernel.org/stable/c/25dd54b95abfdca423b65a4ee620a774777d8213
- https://git.kernel.org/stable/c/2c231a247a1d1628e41fa1eefd1a5307c41c5f53
- https://git.kernel.org/stable/c/354a6e707e29cb0c007176ee5b8db8be7bd2dee0
- https://git.kernel.org/stable/c/6584eba7688dcf999542778b07f63828c21521da
Get alerted when CVE-2023-52507 or the next vulnerability affects your stack