What’s Vulnerable › Vulnerabilities
CVE-2023-52557: OpenBSD 7.3 invalid l2tp message npppd crash
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-131
Description
In OpenBSD 7.3 before errata 016, npppd(8) could crash by a l2tp message which has an AVP (Attribute-Value Pair) with wrong length.
Affected products
- OpenBSD: before 7.3; 7.3, 7.3-errata_001, 7.3-errata_002, 7.3-errata_003, 7.3-errata_004, 7.3-errata_005 (+10) — fixed in 7.3
How to fix
Upgrade to a fixed version: OpenBSD 7.3. Check the vendor advisory for mitigations.
References
- https://ftp.openbsd.org/pub/OpenBSD/patches/7.3/common/016_npppd.patch.sig
- https://github.com/openbsd/src/commit/abf3a29384c582c807a621e7fc6e7c68d0cafe9b
- https://ftp.openbsd.org/pub/OpenBSD/patches/7.3/common/016_npppd.patch.sig
- https://github.com/openbsd/src/commit/abf3a29384c582c807a621e7fc6e7c68d0cafe9b
Get alerted when CVE-2023-52557 or the next vulnerability affects your stack