What’s Vulnerable › Vulnerabilities
CVE-2023-5256: Drupal core - Critical - Cache poisoning - SA-CORE-2023-006
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-28 · updated 2026-06-17
- Weakness: CWE-200
Description
In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation. This vulnerability only affects sites with the JSON:API module enabled, and can be mitigated by uninstalling JSON:API. The core REST and contributed GraphQL modules are not affected.
Affected products
- Drupal: from 8.7.0 before 9.5.11; from 10.0.0 before 10.0.11; from 10.1.0 before 10.1.4 — fixed in 10.0.11, 10.1.4, 9.5.11
How to fix
Upgrade to a fixed version: Drupal 10.0.11, 10.1.4, 9.5.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-5256 or the next vulnerability affects your stack