What’s Vulnerable › Vulnerabilities
CVE-2023-52581: netfilter: nf_tables: fix memleak when more than 255 elements expired
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-02 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: netfilter: nf_tables: fix memleak when more than 255 elements expired When more than 255 elements expired we're supposed to switch to a new gc container structure. This never happens: u8 type will wrap before reaching the boundary and nft_trans_gc_space() always returns true. This means we recycle the initial gc container structure and lose track of the elements that came before. While at it, don't deref 'gc' after we've passed it to call_rcu.
Affected products
- Linux kernel: from 6.5 before 6.5.6; 6.6-rc1, 6.6-rc2 — fixed in 6.5.6
How to fix
Upgrade to a fixed version: Linux kernel 6.5.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09c85f2d21ab6b5acba31a037985b13e8e6565b8
- https://git.kernel.org/stable/c/4aea243b6853d06c1d160a9955b759189aa02b14
- https://git.kernel.org/stable/c/7cf055b43756b10aa2b851c927c940f5ed652125
- https://git.kernel.org/stable/c/7e5d732e6902eb6a37b35480796838a145ae5f07
- https://git.kernel.org/stable/c/a995a68e8a3b48533e47c856865d109a1f1a9d01
- https://git.kernel.org/stable/c/cf5000a7787cbc10341091d37245a42c119d26c5
- https://git.kernel.org/stable/c/ef99506eaf1dc31feff1adfcfd68bc5535a22171
- https://git.kernel.org/stable/c/09c85f2d21ab6b5acba31a037985b13e8e6565b8
- https://git.kernel.org/stable/c/4aea243b6853d06c1d160a9955b759189aa02b14
- https://git.kernel.org/stable/c/7cf055b43756b10aa2b851c927c940f5ed652125
- https://git.kernel.org/stable/c/7e5d732e6902eb6a37b35480796838a145ae5f07
- https://git.kernel.org/stable/c/a995a68e8a3b48533e47c856865d109a1f1a9d01
Get alerted when CVE-2023-52581 or the next vulnerability affects your stack