What’s Vulnerable › Vulnerabilities
CVE-2023-52612: crypto: scomp - fix req->dst buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-18 · updated 2026-10-15
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: scomp - fix req->dst buffer overflow The req->dst buffer size should be checked before copying from the scomp_scratch->dst to avoid req->dst buffer overflow problem.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.10 before 4.19.306; from 4.20 before 5.4.268; from 5.5 before 5.10.209; from 5.11 before 5.15.148; from 5.16 before 6.1.75; from 6.2 before 6.6.14 — fixed in 4.19.306, 5.10.209, 5.15.148, 5.4.268, 6.1.75, 6.6.14
How to fix
Upgrade to a fixed version: Linux kernel 4.19.306, 5.10.209, 5.15.148, 5.4.268. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1142d65c5b881590962ad763f94505b6dd67d2fe
- https://git.kernel.org/stable/c/4518dc468cdd796757190515a9be7408adc8911e
- https://git.kernel.org/stable/c/4df0c942d04a67df174195ad8082f6e30e7f71a5
- https://git.kernel.org/stable/c/71c6670f9f032ec67d8f4e3f8db4646bf5a62883
- https://git.kernel.org/stable/c/744e1885922a9943458954cfea917b31064b4131
- https://git.kernel.org/stable/c/7d9e5bed036a7f9e2062a137e97e3c1e77fb8759
- https://git.kernel.org/stable/c/a5f2f91b3fd7387e5102060809316a0f8f0bc625
- https://git.kernel.org/stable/c/e0e3f4a18784182cfe34e20c00eca11e78d53e76
- https://git.kernel.org/stable/c/1142d65c5b881590962ad763f94505b6dd67d2fe
- https://git.kernel.org/stable/c/4518dc468cdd796757190515a9be7408adc8911e
- https://git.kernel.org/stable/c/4df0c942d04a67df174195ad8082f6e30e7f71a5
- https://git.kernel.org/stable/c/71c6670f9f032ec67d8f4e3f8db4646bf5a62883
Get alerted when CVE-2023-52612 or the next vulnerability affects your stack