What’s Vulnerable › Vulnerabilities
CVE-2023-52645: pmdomain: mediatek: fix race conditions with genpd
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: pmdomain: mediatek: fix race conditions with genpd If the power domains are registered first with genpd and *after that* the driver attempts to power them on in the probe sequence, then it is possible that a race condition occurs if genpd tries to power them on in the same time. The same is valid for powering them off before unregistering them from genpd. Attempt to fix race conditions by first removing the domains from genpd and *after that* powering down domains. Also first power up the domains and *after that* register them to genpd.
Affected products
- Linux kernel: from 5.11 before 5.15.150; from 5.16 before 6.1.80; from 6.2 before 6.6.18; from 6.7 before 6.7.6 — fixed in 5.15.150, 6.1.80, 6.6.18, 6.7.6
How to fix
Upgrade to a fixed version: Linux kernel 5.15.150, 6.1.80, 6.6.18, 6.7.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/339ddc983bc1622341d95f244c361cda3da3a4ff
- https://git.kernel.org/stable/c/3cd1d92ee1dbf3e8f988767eb75f26207397792b
- https://git.kernel.org/stable/c/475426ad1ae0bfdfd8f160ed9750903799392438
- https://git.kernel.org/stable/c/c41336f4d69057cbf88fed47951379b384540df5
- https://git.kernel.org/stable/c/f83b9abee9faa4868a6fac4669b86f4c215dae25
- https://git.kernel.org/stable/c/339ddc983bc1622341d95f244c361cda3da3a4ff
- https://git.kernel.org/stable/c/3cd1d92ee1dbf3e8f988767eb75f26207397792b
- https://git.kernel.org/stable/c/475426ad1ae0bfdfd8f160ed9750903799392438
- https://git.kernel.org/stable/c/c41336f4d69057cbf88fed47951379b384540df5
- https://git.kernel.org/stable/c/f83b9abee9faa4868a6fac4669b86f4c215dae25
Get alerted when CVE-2023-52645 or the next vulnerability affects your stack