What’s Vulnerable › Vulnerabilities
CVE-2023-52649: drm/vkms: Avoid reading beyond LUT array
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/vkms: Avoid reading beyond LUT array When the floor LUT index (drm_fixp2int(lut_index) is the last index of the array the ceil LUT index will point to an entry beyond the array. Make sure we guard against it and use the value of the floor LUT index. v3: - Drop bits from commit description that didn't contribute anything of value
Affected products
- Linux kernel: from 6.6 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 6.6.23, 6.7.11, 6.8.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/046c1184ce60b0a37d48134f17ddbc1f32ce02bd
- https://git.kernel.org/stable/c/2fee84030d12d9fddfa874e4562d71761a129277
- https://git.kernel.org/stable/c/92800aaeff51b8358d1e0a7eb74daf8aa2d7ce9d
- https://git.kernel.org/stable/c/9556c167673057d48ce4a0da675026fe046654c1
- https://git.kernel.org/stable/c/046c1184ce60b0a37d48134f17ddbc1f32ce02bd
- https://git.kernel.org/stable/c/2fee84030d12d9fddfa874e4562d71761a129277
- https://git.kernel.org/stable/c/92800aaeff51b8358d1e0a7eb74daf8aa2d7ce9d
- https://git.kernel.org/stable/c/9556c167673057d48ce4a0da675026fe046654c1
Get alerted when CVE-2023-52649 or the next vulnerability affects your stack