What’s Vulnerable › Vulnerabilities
CVE-2023-52683: ACPI: LPIT: Avoid u32 multiplication overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ACPI: LPIT: Avoid u32 multiplication overflow In lpit_update_residency() there is a possibility of overflow in multiplication, if tsc_khz is large enough (> UINT_MAX/1000). Change multiplication to mul_u32_u32(). Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.15 before 4.19.306; from 4.20 before 5.4.268; from 5.5 before 5.10.209; from 5.11 before 5.15.148; from 5.16 before 6.1.75; from 6.2 before 6.6.14 — fixed in 4.19.306, 5.10.209, 5.15.148, 5.4.268, 6.1.75, 6.6.14
How to fix
Upgrade to a fixed version: Linux kernel 4.19.306, 5.10.209, 5.15.148, 5.4.268. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/56d2eeda87995245300836ee4dbd13b002311782
- https://git.kernel.org/stable/c/647d1d50c31e60ef9ccb9756a8fdf863329f7aee
- https://git.kernel.org/stable/c/6c38e791bde07d6ca2a0a619ff9b6837e0d5f9ad
- https://git.kernel.org/stable/c/72222dfd76a79d9666ab3117fcdd44ca8cd0c4de
- https://git.kernel.org/stable/c/b7aab9d906e2e252a7783f872406033ec49b6dae
- https://git.kernel.org/stable/c/c1814a4ffd016ce5392c6767d22ef3aa2f0d4bd1
- https://git.kernel.org/stable/c/d1ac288b2742aa4af746c5613bac71760fadd1c4
- https://git.kernel.org/stable/c/f39c3d578c7d09a18ceaf56750fc7f20b02ada63
- https://git.kernel.org/stable/c/56d2eeda87995245300836ee4dbd13b002311782
- https://git.kernel.org/stable/c/647d1d50c31e60ef9ccb9756a8fdf863329f7aee
- https://git.kernel.org/stable/c/6c38e791bde07d6ca2a0a619ff9b6837e0d5f9ad
- https://git.kernel.org/stable/c/72222dfd76a79d9666ab3117fcdd44ca8cd0c4de
Get alerted when CVE-2023-52683 or the next vulnerability affects your stack