What’s Vulnerable › Vulnerabilities
CVE-2023-52746: xfrm/compat: prevent potential spectre v1 gadget in xfrm_xlate32_attr()
- Severity: low (CVSS 2.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: xfrm/compat: prevent potential spectre v1 gadget in xfrm_xlate32_attr() int type = nla_type(nla); if (type > XFRMA_MAX) { return -EOPNOTSUPP; } @type is then used as an array index and can be used as a Spectre v1 gadget. if (nla_len(nla) < compat_policy[type].len) { array_index_nospec() can be used to prevent leaking content of kernel memory to malicious users.
Affected products
- Linux kernel: from 5.10 before 5.10.168; from 5.11 before 5.15.94; from 5.16 before 6.1.12; 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4, 6.2-rc5, 6.2-rc6 (+1) — fixed in 5.10.168, 5.15.94, 6.1.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.168, 5.15.94, 6.1.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/419674224390fca298020fc0751a20812f84b12d
- https://git.kernel.org/stable/c/5dc688fae6b7be9dbbf5304a3d2520d038e06db5
- https://git.kernel.org/stable/c/a893cc644812728e86e9aff517fd5698812ecef0
- https://git.kernel.org/stable/c/b6ee896385380aa621102e8ea402ba12db1cabff
- https://git.kernel.org/stable/c/419674224390fca298020fc0751a20812f84b12d
- https://git.kernel.org/stable/c/5dc688fae6b7be9dbbf5304a3d2520d038e06db5
- https://git.kernel.org/stable/c/a893cc644812728e86e9aff517fd5698812ecef0
- https://git.kernel.org/stable/c/b6ee896385380aa621102e8ea402ba12db1cabff
Get alerted when CVE-2023-52746 or the next vulnerability affects your stack