What’s Vulnerable › Vulnerabilities
CVE-2023-52768: wifi: wilc1000: use vmm_table as array in wilc struct
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: wilc1000: use vmm_table as array in wilc struct Enabling KASAN and running some iperf tests raises some memory issues with vmm_table: BUG: KASAN: slab-out-of-bounds in wilc_wlan_handle_txq+0x6ac/0xdb4 Write of size 4 at addr c3a61540 by task wlan0-tx/95 KASAN detects that we are writing data beyond range allocated to vmm_table. There is indeed a mismatch between the size passed to allocator in wilc_wlan_init, and the range of possible indexes used later: allocation size is missing a multiplication by sizeof(u32)
Affected products
- Linux kernel: from 5.15.68 before 5.15.140; from 5.19.9 before 6.1.64; from 6.2 before 6.5.13; from 6.6 before 6.6.3 — fixed in 5.15.140, 6.1.64, 6.5.13, 6.6.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.140, 6.1.64, 6.5.13, 6.6.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05ac1a198a63ad66bf5ae8b7321407c102d40ef3
- https://git.kernel.org/stable/c/3ce1c2c3999b232258f7aabab311d47dda75605c
- https://git.kernel.org/stable/c/4b0d6ddb6466d10df878a7787f175a0e4adc3e27
- https://git.kernel.org/stable/c/541b3757fd443a68ed8d25968eae511a8275e7c8
- https://git.kernel.org/stable/c/6aaf7cd8bdfe245d3c9a8b48fe70c2011965948e
- https://git.kernel.org/stable/c/05ac1a198a63ad66bf5ae8b7321407c102d40ef3
- https://git.kernel.org/stable/c/3ce1c2c3999b232258f7aabab311d47dda75605c
- https://git.kernel.org/stable/c/4b0d6ddb6466d10df878a7787f175a0e4adc3e27
- https://git.kernel.org/stable/c/541b3757fd443a68ed8d25968eae511a8275e7c8
- https://git.kernel.org/stable/c/6aaf7cd8bdfe245d3c9a8b48fe70c2011965948e
Get alerted when CVE-2023-52768 or the next vulnerability affects your stack