What’s Vulnerable › Vulnerabilities
CVE-2023-52789: tty: vcc: Add check for kstrdup() in vcc_probe()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: tty: vcc: Add check for kstrdup() in vcc_probe() Add check for the return value of kstrdup() and return the error, if it fails in order to avoid NULL pointer dereference.
Affected products
- Linux kernel: before 4.14.331; from 4.15 before 4.19.300; from 4.20 before 5.4.262; from 5.5 before 5.10.202; from 5.11 before 5.15.140; from 5.16 before 6.1.64 — fixed in 4.14.331, 4.19.300, 5.10.202, 5.15.140, 5.4.262, 6.1.64
How to fix
Upgrade to a fixed version: Linux kernel 4.14.331, 4.19.300, 5.10.202, 5.15.140. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/38cd56fc9de78bf3c878790785e8c231116ef9d3
- https://git.kernel.org/stable/c/460284dfb10b207980c6f3f7046e33446ceb38ac
- https://git.kernel.org/stable/c/4a24a31826246b15477399febd13292b0c9f0ee9
- https://git.kernel.org/stable/c/4ef41a7f33ffe1a335e7db7e1564ddc6afad47cc
- https://git.kernel.org/stable/c/6c80f48912b5bd4965352d1a9a989e21743a4a06
- https://git.kernel.org/stable/c/7cebc86481bf16049e266f6774d90f2fd4f8d5d2
- https://git.kernel.org/stable/c/8f8771757b130383732195497e47fba2aba76d3a
- https://git.kernel.org/stable/c/909963e0c16778cec28efb1affc21558825f4200
- https://git.kernel.org/stable/c/d81ffb87aaa75f842cd7aa57091810353755b3e6
- https://git.kernel.org/stable/c/38cd56fc9de78bf3c878790785e8c231116ef9d3
- https://git.kernel.org/stable/c/460284dfb10b207980c6f3f7046e33446ceb38ac
- https://git.kernel.org/stable/c/4a24a31826246b15477399febd13292b0c9f0ee9
Get alerted when CVE-2023-52789 or the next vulnerability affects your stack