What’s Vulnerable › Vulnerabilities
CVE-2023-52800: wifi: ath11k: fix htt pktlog locking
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: ath11k: fix htt pktlog locking The ath11k active pdevs are protected by RCU but the htt pktlog handling code calling ath11k_mac_get_ar_by_pdev_id() was not marked as a read-side critical section. Mark the code in question as an RCU read-side critical section to avoid any potential use-after-free issues. Compile tested only.
Affected products
- Linux kernel: from 5.6 before 5.10.202; from 5.11 before 5.15.140; from 5.16 before 6.1.64; from 6.2 before 6.5.13; from 6.6 before 6.6.3 — fixed in 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.202, 5.15.140, 6.1.64, 6.5.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/03ed26935bebf6b6fd8a656490bf3dcc71b72679
- https://git.kernel.org/stable/c/3a51e6b4da71fdfa43ec006d6abc020f3e22d14e
- https://git.kernel.org/stable/c/3f77c7d605b29df277d77e9ee75d96e7ad145d2d
- https://git.kernel.org/stable/c/423762f021825b5e57c3d6f01ff96a9ff19cdcd8
- https://git.kernel.org/stable/c/69cede2a5a5f60e3f5602b901b52cb64edd2ea6c
- https://git.kernel.org/stable/c/e3199b3fac65c9f103055390b6fd07c5cffa5961
- https://git.kernel.org/stable/c/03ed26935bebf6b6fd8a656490bf3dcc71b72679
- https://git.kernel.org/stable/c/3a51e6b4da71fdfa43ec006d6abc020f3e22d14e
- https://git.kernel.org/stable/c/3f77c7d605b29df277d77e9ee75d96e7ad145d2d
- https://git.kernel.org/stable/c/423762f021825b5e57c3d6f01ff96a9ff19cdcd8
- https://git.kernel.org/stable/c/69cede2a5a5f60e3f5602b901b52cb64edd2ea6c
- https://git.kernel.org/stable/c/e3199b3fac65c9f103055390b6fd07c5cffa5961
Get alerted when CVE-2023-52800 or the next vulnerability affects your stack