What’s Vulnerable › Vulnerabilities
CVE-2023-52804: fs/jfs: Add validity check for db_maxag and db_agpref
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: fs/jfs: Add validity check for db_maxag and db_agpref Both db_maxag and db_agpref are used as the index of the db_agfree array, but there is currently no validity check for db_maxag and db_agpref, which can lead to errors. The following is related bug reported by Syzbot: UBSAN: array-index-out-of-bounds in fs/jfs/jfs_dmap.c:639:20 index 7936 is out of range for type 'atomic_t[128]' Add checking that the values of db_maxag and db_agpref are valid indexes for the db_agfree array.
Affected products
- Linux kernel: before 4.14.331; from 4.15 before 4.19.300; from 4.20 before 5.4.262; from 5.5 before 5.10.202; from 5.11 before 5.15.140; from 5.16 before 6.1.64 — fixed in 4.14.331, 4.19.300, 5.10.202, 5.15.140, 5.4.262, 6.1.64
How to fix
Upgrade to a fixed version: Linux kernel 4.14.331, 4.19.300, 5.10.202, 5.15.140. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1f74d336990f37703a8eee77153463d65b67f70e
- https://git.kernel.org/stable/c/2323de34a3ae61a9f9b544c18583f71cea86721f
- https://git.kernel.org/stable/c/32bd8f1cbcf8b663e29dd1f908ba3a129541a11b
- https://git.kernel.org/stable/c/5013f8269887642cca784adc8db9b5f0b771533f
- https://git.kernel.org/stable/c/64933ab7b04881c6c18b21ff206c12278341c72e
- https://git.kernel.org/stable/c/a0649e2dd4a3595b5595a29d0064d047c2fae2fb
- https://git.kernel.org/stable/c/c6c8863fb3f57700ab583d875adda04caaf2278a
- https://git.kernel.org/stable/c/ce15b0f1a431168f07b1cc6c9f71206a2db5c809
- https://git.kernel.org/stable/c/dca403bb035a565bb98ecc1dda5d30f676feda40
- https://git.kernel.org/stable/c/1f74d336990f37703a8eee77153463d65b67f70e
- https://git.kernel.org/stable/c/2323de34a3ae61a9f9b544c18583f71cea86721f
- https://git.kernel.org/stable/c/32bd8f1cbcf8b663e29dd1f908ba3a129541a11b
Get alerted when CVE-2023-52804 or the next vulnerability affects your stack