What’s Vulnerable › Vulnerabilities
CVE-2023-52805: jfs: fix array-index-out-of-bounds in diAlloc
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: jfs: fix array-index-out-of-bounds in diAlloc Currently there is not check against the agno of the iag while allocating new inodes to avoid fragmentation problem. Added the check which is required.
Affected products
- Linux kernel: before 4.14.331; from 4.15 before 4.19.300; from 4.20 before 5.4.262; from 5.5 before 5.10.202; from 5.11 before 5.15.140; from 5.16 before 6.1.64 — fixed in 4.14.331, 4.19.300, 5.10.202, 5.15.140, 5.4.262, 6.1.64
How to fix
Upgrade to a fixed version: Linux kernel 4.14.331, 4.19.300, 5.10.202, 5.15.140. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05d9ea1ceb62a55af6727a69269a4fd310edf483
- https://git.kernel.org/stable/c/1708d0a9917fea579cc9da3d87b154285abd2cd8
- https://git.kernel.org/stable/c/1ba7df5457dc1c1071c5f92ac11323533a6430e1
- https://git.kernel.org/stable/c/2308d0fb0dc32446b4e6ca37cd09c30374bb64e9
- https://git.kernel.org/stable/c/64f062baf202b82f54987a3f614a6c8f3e466641
- https://git.kernel.org/stable/c/665b44e55c2767a4f899c3b18f49e9e1c9983777
- https://git.kernel.org/stable/c/7467ca10a5ff09b0e87edf6c4d2a4bfdee69cf2c
- https://git.kernel.org/stable/c/8c68af2af697ba2ba3b138be0c6d72e2ce3a3d6d
- https://git.kernel.org/stable/c/cf7e3e84df36a9953796c737f080712f631d7083
- https://git.kernel.org/stable/c/05d9ea1ceb62a55af6727a69269a4fd310edf483
- https://git.kernel.org/stable/c/1708d0a9917fea579cc9da3d87b154285abd2cd8
- https://git.kernel.org/stable/c/1ba7df5457dc1c1071c5f92ac11323533a6430e1
Get alerted when CVE-2023-52805 or the next vulnerability affects your stack