What’s Vulnerable › Vulnerabilities
CVE-2023-52812: drm/amd: check num of link levels when update pcie param
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd: check num of link levels when update pcie param In SR-IOV environment, the value of pcie_table->num_of_link_levels will be 0, and num_of_levels - 1 will cause array index out of bounds
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.19 before 6.1.119; from 6.2 before 6.5.13; from 6.6 before 6.6.3 — fixed in 6.1.119, 6.5.13, 6.6.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.119, 6.5.13, 6.6.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09f617219fe9ccd8d7b65dc3e879b5889f663b5a
- https://git.kernel.org/stable/c/2f2d48b6247ae3001f83c98730b3cce475cb2927
- https://git.kernel.org/stable/c/406e8845356d18bdf3d3a23b347faf67706472ec
- https://git.kernel.org/stable/c/5b4574b663d0a1a0a62d5232429b7db9ae6d0670
- https://git.kernel.org/stable/c/09f617219fe9ccd8d7b65dc3e879b5889f663b5a
- https://git.kernel.org/stable/c/406e8845356d18bdf3d3a23b347faf67706472ec
- https://git.kernel.org/stable/c/5b4574b663d0a1a0a62d5232429b7db9ae6d0670
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2023-52812 or the next vulnerability affects your stack