What’s Vulnerable › Vulnerabilities
CVE-2023-52827: wifi: ath12k: fix possible out-of-bound read in ath12k_htt_pull_ppdu_stats()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: ath12k: fix possible out-of-bound read in ath12k_htt_pull_ppdu_stats() len is extracted from HTT message and could be an unexpected value in case errors happen, so add validation before using to avoid possible out-of-bound read in the following message iteration and parsing. The same issue also applies to ppdu_info->ppdu_stats.common.num_users, so validate it before using too. These are found during code review. Compile test only.
Affected products
- Linux kernel: before 6.5.13; from 6.6 before 6.6.3 — fixed in 6.5.13, 6.6.3
How to fix
Upgrade to a fixed version: Linux kernel 6.5.13, 6.6.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1bc44a505a229bb1dd4957e11aa594edeea3690e
- https://git.kernel.org/stable/c/79527c21a3ce04cffc35ea54f74ee087e532be57
- https://git.kernel.org/stable/c/c9e44111da221246efb2e623ae1be40a5cf6542c
- https://git.kernel.org/stable/c/1bc44a505a229bb1dd4957e11aa594edeea3690e
- https://git.kernel.org/stable/c/79527c21a3ce04cffc35ea54f74ee087e532be57
- https://git.kernel.org/stable/c/c9e44111da221246efb2e623ae1be40a5cf6542c
Get alerted when CVE-2023-52827 or the next vulnerability affects your stack