What’s Vulnerable › Vulnerabilities
CVE-2023-52840: Input: synaptics-rmi4 - fix use after free in rmi_unregister_function()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: Input: synaptics-rmi4 - fix use after free in rmi_unregister_function() The put_device() calls rmi_release_function() which frees "fn" so the dereference on the next line "fn->num_of_irqs" is a use after free. Move the put_device() to the end to fix this.
Affected products
- Linux kernel: from 4.18 before 4.19.299; from 4.20 before 5.4.261; from 5.5 before 5.10.201; from 5.11 before 5.15.139; from 5.16 before 6.1.63; from 6.2 before 6.5.12 — fixed in 4.19.299, 5.10.201, 5.15.139, 5.4.261, 6.1.63, 6.5.12
How to fix
Upgrade to a fixed version: Linux kernel 4.19.299, 5.10.201, 5.15.139, 5.4.261. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2f236d8638f5b43e0c72919a6a27fe286c32053f
- https://git.kernel.org/stable/c/303766bb92c5c225cf40f9bbbe7e29749406e2f2
- https://git.kernel.org/stable/c/50d12253666195a14c6cd2b81c376e2dbeedbdff
- https://git.kernel.org/stable/c/6c71e065befb2fae8f1461559b940c04e1071bd5
- https://git.kernel.org/stable/c/7082b1fb5321037bc11ba1cf2d7ed23c6b2b521f
- https://git.kernel.org/stable/c/c8e639f5743cf4b01f8c65e0df075fe4d782b585
- https://git.kernel.org/stable/c/cc56c4d17721dcb10ad4e9c9266e449be1462683
- https://git.kernel.org/stable/c/eb988e46da2e4eae89f5337e047ce372fe33d5b1
- https://git.kernel.org/stable/c/2f236d8638f5b43e0c72919a6a27fe286c32053f
- https://git.kernel.org/stable/c/303766bb92c5c225cf40f9bbbe7e29749406e2f2
- https://git.kernel.org/stable/c/50d12253666195a14c6cd2b81c376e2dbeedbdff
- https://git.kernel.org/stable/c/6c71e065befb2fae8f1461559b940c04e1071bd5
Get alerted when CVE-2023-52840 or the next vulnerability affects your stack