What’s Vulnerable › Vulnerabilities
CVE-2023-52868: thermal: core: prevent potential string overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: thermal: core: prevent potential string overflow The dev->id value comes from ida_alloc() so it's a number between zero and INT_MAX. If it's too high then these sprintf()s will overflow.
Affected products
- Linux kernel: from 2.6.25 before 4.14.330; from 4.15 before 4.19.299; from 4.20 before 5.4.261; from 5.5 before 5.10.201; from 5.11 before 5.15.139; from 5.16 before 6.1.63 — fixed in 4.14.330, 4.19.299, 5.10.201, 5.15.139, 5.4.261, 6.1.63
How to fix
Upgrade to a fixed version: Linux kernel 4.14.330, 4.19.299, 5.10.201, 5.15.139. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f6b3be28c4d62ef6498133959c72266629bea97
- https://git.kernel.org/stable/c/3091ab943dfc7b2578599b0fe203350286fab5bb
- https://git.kernel.org/stable/c/3a8f4e58e1ee707b4f46a1000b40b86ea3dd509c
- https://git.kernel.org/stable/c/3f795fb35c2d8a637efe76b4518216c9319b998c
- https://git.kernel.org/stable/c/6ad1bf47fbe5750c4d5d8e41337665e193e2c521
- https://git.kernel.org/stable/c/77ff34a56b695e228e6daf30ee30be747973d6e8
- https://git.kernel.org/stable/c/b55f0a9f865be75ca1019aad331f3225f7b50ce8
- https://git.kernel.org/stable/c/c99626092efca3061b387043d4a7399bf75fbdd5
- https://git.kernel.org/stable/c/edbd6bbe40ac524a8f2273ffacc53edf14f3c686
- https://git.kernel.org/stable/c/0f6b3be28c4d62ef6498133959c72266629bea97
- https://git.kernel.org/stable/c/3091ab943dfc7b2578599b0fe203350286fab5bb
- https://git.kernel.org/stable/c/3a8f4e58e1ee707b4f46a1000b40b86ea3dd509c
Get alerted when CVE-2023-52868 or the next vulnerability affects your stack