What’s Vulnerable › Vulnerabilities
CVE-2023-52878: can: dev: can_put_echo_skb(): don't crash kernel if can_priv::echo_skb is accessed out of bounds
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: can: dev: can_put_echo_skb(): don't crash kernel if can_priv::echo_skb is accessed out of bounds If the "struct can_priv::echoo_skb" is accessed out of bounds, this would cause a kernel crash. Instead, issue a meaningful warning message and return with an error.
Affected products
- Linux kernel: from 2.6.33 before 5.15.139; from 5.16 before 6.1.63; from 6.2 before 6.5.12; from 6.6 before 6.6.2 — fixed in 5.15.139, 6.1.63, 6.5.12, 6.6.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.139, 6.1.63, 6.5.12, 6.6.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d30931f1fa0fb893fb7d5dc32b6b7edfb775be4
- https://git.kernel.org/stable/c/53c468008a7c9ca3f5fc985951f35ec2acae85bc
- https://git.kernel.org/stable/c/6411959c10fe917288cbb1038886999148560057
- https://git.kernel.org/stable/c/826120c9ba68f2d0dbae58e99013929c883d1444
- https://git.kernel.org/stable/c/8ab67da060157362b2e0926692c659808784708f
- https://git.kernel.org/stable/c/0d30931f1fa0fb893fb7d5dc32b6b7edfb775be4
- https://git.kernel.org/stable/c/53c468008a7c9ca3f5fc985951f35ec2acae85bc
- https://git.kernel.org/stable/c/6411959c10fe917288cbb1038886999148560057
- https://git.kernel.org/stable/c/826120c9ba68f2d0dbae58e99013929c883d1444
- https://git.kernel.org/stable/c/8ab67da060157362b2e0926692c659808784708f
Get alerted when CVE-2023-52878 or the next vulnerability affects your stack