What’s Vulnerable › Vulnerabilities
CVE-2023-52880: tty: n_gsm: require CAP_NET_ADMIN to attach N_GSM0710 ldisc
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-24 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: tty: n_gsm: require CAP_NET_ADMIN to attach N_GSM0710 ldisc Any unprivileged user can attach N_GSM0710 ldisc, but it requires CAP_NET_ADMIN to create a GSM network anyway. Require initial namespace CAP_NET_ADMIN to do that.
Affected products
- Debian Linux: 10.0
- Linux kernel: before 4.19.312; from 4.20 before 5.4.274; from 5.5 before 5.10.215; from 5.11 before 5.15.155; from 5.16 before 6.1.86; from 6.2 before 6.6 — fixed in 4.19.312, 5.10.215, 5.15.155, 5.4.274, 6.1.86, 6.6
How to fix
Upgrade to a fixed version: Linux kernel 4.19.312, 5.10.215, 5.15.155, 5.4.274. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2b85977977cbd120591b23c2450e90a5806a7167
- https://git.kernel.org/stable/c/2d154a54c58f9c8375bfbea9f7e51ba3bfb2e43a
- https://git.kernel.org/stable/c/67c37756898a5a6b2941a13ae7260c89b54e0d88
- https://git.kernel.org/stable/c/7a529c9023a197ab3bf09bb95df32a3813f7ba58
- https://git.kernel.org/stable/c/7d303dee473ba3529d75b63491e9963342107bed
- https://git.kernel.org/stable/c/ada28eb4b9561aab93942f3224a2e41d76fe57fa
- https://git.kernel.org/stable/c/2b85977977cbd120591b23c2450e90a5806a7167
- https://git.kernel.org/stable/c/2d154a54c58f9c8375bfbea9f7e51ba3bfb2e43a
- https://git.kernel.org/stable/c/67c37756898a5a6b2941a13ae7260c89b54e0d88
- https://git.kernel.org/stable/c/7a529c9023a197ab3bf09bb95df32a3813f7ba58
- https://git.kernel.org/stable/c/7d303dee473ba3529d75b63491e9963342107bed
- https://git.kernel.org/stable/c/ada28eb4b9561aab93942f3224a2e41d76fe57fa
Get alerted when CVE-2023-52880 or the next vulnerability affects your stack