What’s Vulnerable › Vulnerabilities
CVE-2023-52918: media: pci: cx23885: check cx23885_vdev_init() return
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: media: pci: cx23885: check cx23885_vdev_init() return cx23885_vdev_init() can return a NULL pointer, but that pointer is used in the next line without a check. Add a NULL pointer check and go to the error unwind if it is NULL.
Affected products
- Linux kernel: before 4.19.321; from 4.20 before 5.4.283; from 5.5 before 5.10.225; from 5.11 before 5.15.166; from 5.16 before 6.1.107; from 6.2 before 6.6.48 — fixed in 4.19.321, 5.10.225, 5.15.166, 5.4.283, 6.1.107, 6.6.48
How to fix
Upgrade to a fixed version: Linux kernel 4.19.321, 5.10.225, 5.15.166, 5.4.283. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06ee04a907d64ee3910fecedd05d7f1be4b1b70e
- https://git.kernel.org/stable/c/15126b916e39b0cb67026b0af3c014bfeb1f76b3
- https://git.kernel.org/stable/c/199a42fc4c45e8b7f19efeb15dbc36889a599ac2
- https://git.kernel.org/stable/c/8e31b096e2e1949bc8f0be019c9ae70d414404c6
- https://git.kernel.org/stable/c/a5f1d30c51c485cec7a7de60205667c3ff86c303
- https://git.kernel.org/stable/c/b1397fb4a779fca560c43d2acf6702d41b4a495b
- https://git.kernel.org/stable/c/e7385510e2550a9f8b6f3d5f33c5b894ab9ba976
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2023-52918 or the next vulnerability affects your stack