What’s Vulnerable › Vulnerabilities
CVE-2023-52931: drm/i915: Avoid potential vm use-after-free
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: drm/i915: Avoid potential vm use-after-free Adding the vm to the vm_xa table makes it visible to userspace, which could try to race with us to close the vm. So we need to take our extra reference before putting it in the table. (cherry picked from commit 99343c46d4e2b34c285d3d5f68ff04274c2f9fb4)
Affected products
- Linux kernel: from 5.16 before 6.1.11; 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4, 6.2-rc5, 6.2-rc6 — fixed in 6.1.11
How to fix
Upgrade to a fixed version: Linux kernel 6.1.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/41d419382ec7e257e54b7b6ff0d3623aafb1316d
- https://git.kernel.org/stable/c/764accc2c1b8fd1507be2e7f436c94cdce887a00
Get alerted when CVE-2023-52931 or the next vulnerability affects your stack