What’s Vulnerable › Vulnerabilities

CVE-2023-52968

Description

MariaDB Server 10.4 before 10.4.33, 10.5 before 10.5.24, 10.6 before 10.6.17, 10.7 through 10.11 before 10.11.7, 11.0 before 11.0.5, and 11.1 before 11.1.4 calls fix_fields_if_needed under mysql_derived_prepare when derived is not yet prepared, leading to a find_field_in_table crash.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.11.7, 10.4.33, 10.5.24, 10.6.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-52968 or the next vulnerability affects your stack