What’s Vulnerable › Vulnerabilities
CVE-2023-52996: ipv4: prevent potential spectre v1 gadget in fib_metrics_match()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ipv4: prevent potential spectre v1 gadget in fib_metrics_match() if (!type) continue; if (type > RTAX_MAX) return false; ... fi_val = fi->fib_metrics->metrics[type - 1]; @type being used as an array index, we need to prevent cpu speculation or risk leaking kernel memory content.
Affected products
- Linux kernel: from 4.14 before 5.4.231; from 5.5 before 5.10.166; from 5.11 before 5.15.91; from 5.16 before 6.1.9; 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4, 6.2-rc5 — fixed in 5.10.166, 5.15.91, 5.4.231, 6.1.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.166, 5.15.91, 5.4.231, 6.1.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5e9398a26a92fc402d82ce1f97cc67d832527da0
- https://git.kernel.org/stable/c/7f9828fb1f688210e681268490576f0ca65c322a
- https://git.kernel.org/stable/c/8f0eb24f1a7a60ce635f0d757a46f1a37a4d467d
- https://git.kernel.org/stable/c/ca3cf947760de050d558293002ad3e7f4b8745d2
- https://git.kernel.org/stable/c/f9753ebd61be2d957b5504cbd3fd719674f05b7a
Get alerted when CVE-2023-52996 or the next vulnerability affects your stack