What’s Vulnerable › Vulnerabilities
CVE-2023-53000: netlink: prevent potential spectre v1 gadgets
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: netlink: prevent potential spectre v1 gadgets Most netlink attributes are parsed and validated from __nla_validate_parse() or validate_nla() u16 type = nla_type(nla); if (type == 0 || type > maxtype) { /* error or continue */ } @type is then used as an array index and can be used as a Spectre v1 gadget. array_index_nospec() can be used to prevent leaking content of kernel memory to malicious users. This should take care of vast majority of netlink uses, but an audit is needed to take care of others where validation is not yet centralized in core netlink functions.
Affected products
- Linux kernel: from 2.6.15 before 5.4.231; from 5.5 before 5.10.166; from 5.11 before 5.15.91; from 5.16 before 6.1.9; 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4, 6.2-rc5 — fixed in 5.10.166, 5.15.91, 5.4.231, 6.1.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.166, 5.15.91, 5.4.231, 6.1.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3e5082b1c66c7783fbcd79b5b178573230e528ff
- https://git.kernel.org/stable/c/41b74e95f297ac360ca7ed6bf200100717cb6c45
- https://git.kernel.org/stable/c/539ca5dcbc91134bbe2c45677811c31d8b030d2d
- https://git.kernel.org/stable/c/992e4ff7116a77968039277b5d6aaa535c2f2184
- https://git.kernel.org/stable/c/f0950402e8c76e7dcb08563f1b4e8000fbc62455
Get alerted when CVE-2023-53000 or the next vulnerability affects your stack