What’s Vulnerable › Vulnerabilities
CVE-2023-53032: netfilter: ipset: Fix overflow before widen in the bitmap_ip_create() function.
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: netfilter: ipset: Fix overflow before widen in the bitmap_ip_create() function. When first_ip is 0, last_ip is 0xFFFFFFFF, and netmask is 31, the value of an arithmetic expression 2 << (netmask - mask_bits - 1) is subject to overflow due to a failure casting operands to a larger data type before performing the arithmetic. Note that it's harmless since the value will be checked at the next step. Found by InfoTeCS on behalf of Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 3.7 before 4.14.303; from 4.15 before 4.19.270; from 4.20 before 5.4.229; from 5.5 before 5.10.164; from 5.11 before 5.15.89; from 5.16 before 6.1.7 — fixed in 4.14.303, 4.19.270, 5.10.164, 5.15.89, 5.4.229, 6.1.7
How to fix
Upgrade to a fixed version: Linux kernel 4.14.303, 4.19.270, 5.10.164, 5.15.89. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4e6a70fd840400e3a2e784a6673968a3eb2431c0
- https://git.kernel.org/stable/c/511cf17b2447fc41cfef8d71936e1fa53e395c1e
- https://git.kernel.org/stable/c/9ea4b476cea1b7d461d16dda25ca3c7e616e2d15
- https://git.kernel.org/stable/c/dfd834ccc1b88bbbab81b9046a3a539dd0c2d14f
- https://git.kernel.org/stable/c/e137d9bb26bd85ce07323a38e38ceb0b160db841
- https://git.kernel.org/stable/c/e88865876d47c790be0d5e23973499d75d034364
- https://git.kernel.org/stable/c/feefb33eefa166fc3e0fd17547b0bc0cb3baced9
Get alerted when CVE-2023-53032 or the next vulnerability affects your stack