What’s Vulnerable › Vulnerabilities
CVE-2023-53043: arm64: dts: qcom: sc7280: Mark PCIe controller as cache coherent
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: arm64: dts: qcom: sc7280: Mark PCIe controller as cache coherent If the controller is not marked as cache coherent, then kernel will try to ensure coherency during dma-ops and that may cause data corruption. So, mark the PCIe node as dma-coherent as the devices on PCIe bus are cache coherent.
Affected products
- Linux kernel: from 5.16 before 6.1.22; from 6.2 before 6.2.9; 6.3-rc1, 6.3-rc2, 6.3-rc3 — fixed in 6.1.22, 6.2.9
How to fix
Upgrade to a fixed version: Linux kernel 6.1.22, 6.2.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/267b899375bf38944d915c9654d6eb434edad0ce
- https://git.kernel.org/stable/c/8a63441e83724fee1ef3fd37b237d40d90780766
- https://git.kernel.org/stable/c/e43bba938e2c9104bb4f8bc417ac4d7bb29755e1
Get alerted when CVE-2023-53043 or the next vulnerability affects your stack