What’s Vulnerable › Vulnerabilities
CVE-2023-53062: net: usb: smsc95xx: Limit packet length to skb->len
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: net: usb: smsc95xx: Limit packet length to skb->len Packet length retrieved from descriptor may be larger than the actual socket buffer length. In such case the cloned skb passed up the network stack will leak kernel memory contents.
Affected products
- Linux kernel: from 2.6.28 before 4.14.312; from 4.15 before 4.19.280; from 4.20 before 5.4.240; from 5.5 before 5.10.177; from 5.11 before 5.15.105; from 5.16 before 6.1.22 — fixed in 4.14.312, 4.19.280, 5.10.177, 5.15.105, 5.4.240, 6.1.22
How to fix
Upgrade to a fixed version: Linux kernel 4.14.312, 4.19.280, 5.10.177, 5.15.105. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/33d1603a38e05886c538129ddfe00bd52d347e7b
- https://git.kernel.org/stable/c/70eb25c6a6cde149affe8a587371a3a8ad295ba0
- https://git.kernel.org/stable/c/733580e268a53db1cd01f2251419da91866378f6
- https://git.kernel.org/stable/c/ba6c40227108f8ee428e42eb0337b48ed3001e65
- https://git.kernel.org/stable/c/d3c145a4d24b752c9a1314d5a595014d51471418
- https://git.kernel.org/stable/c/e041bef1adee02999cf24f9a2e15ed452bc363fe
- https://git.kernel.org/stable/c/f2111c791d885211714db85f9a06188571c57dd0
- https://git.kernel.org/stable/c/ff821092cf02a70c2bccd2d19269f01e29aa52cf
Get alerted when CVE-2023-53062 or the next vulnerability affects your stack