What’s Vulnerable › Vulnerabilities
CVE-2023-5311: WP EXtra <= 6.2 - Missing Authorization to .htaccess File Modification
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP EXtra plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the register() function in versions up to, and including, 6.2. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to modify the contents of the .htaccess files located in a site's root directory or /wp-content and /wp-includes folders and achieve remote code execution. CVE-2023-46623 appears to be a duplicate of this issue.
Affected products
- TienCOP WP EXtra: before 6.3 — fixed in 6.3
How to fix
Upgrade to a fixed version: TienCOP WP EXtra 6.3. Check the vendor advisory for mitigations.
References
- https://giongfnef.gitbook.io/giongfnef/cve/cve-2023-5311
- https://plugins.trac.wordpress.org/changeset/2977703/wp-extra
- https://www.wordfence.com/threat-intel/vulnerabilities/id/87e3dd5e-0d77-4d78-8171-0beaf9482699?source=cve
- https://giongfnef.gitbook.io/giongfnef/cve/cve-2023-5311
- https://plugins.trac.wordpress.org/changeset/2977703/wp-extra
- https://www.wordfence.com/threat-intel/vulnerabilities/id/87e3dd5e-0d77-4d78-8171-0beaf9482699?source=cve
Get alerted when CVE-2023-5311 or the next vulnerability affects your stack