What’s Vulnerable › Vulnerabilities
CVE-2023-53117: fs: prevent out-of-bounds array speculation when closing a file descriptor
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: fs: prevent out-of-bounds array speculation when closing a file descriptor Google-Bug-Id: 114199369
Affected products
- Linux kernel: before 4.14.310; from 4.15 before 4.19.278; from 4.20 before 5.4.237; from 5.5 before 5.10.175; from 5.11 before 5.15.103; from 5.16 before 6.1.20 — fixed in 4.14.310, 4.19.278, 5.10.175, 5.15.103, 5.4.237, 6.1.20
How to fix
Upgrade to a fixed version: Linux kernel 4.14.310, 4.19.278, 5.10.175, 5.15.103. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3d5d9501b634fd268eb56428cda92cd317752d69
- https://git.kernel.org/stable/c/609d54441493c99f21c1823dfd66fa7f4c512ff4
- https://git.kernel.org/stable/c/6631c8da02cfad96c53b217cf647b511c7f34faf
- https://git.kernel.org/stable/c/a759905de9cd6ec9ca08ceadf0920272772ed830
- https://git.kernel.org/stable/c/cec08b7d1ebcd3138d4658b3868ce26aeb1e8e06
- https://git.kernel.org/stable/c/eea8e4e056a5ffbeb539a13854c017d5d62c756a
- https://git.kernel.org/stable/c/f31cd5da636682caea424fa1c22679016cbfc16b
- https://git.kernel.org/stable/c/f8cd8754a03a3748384ee438c572423643c9c315
Get alerted when CVE-2023-53117 or the next vulnerability affects your stack