What’s Vulnerable › Vulnerabilities
CVE-2023-53127: scsi: mpi3mr: Fix expander node leak in mpi3mr_remove()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: mpi3mr: Fix expander node leak in mpi3mr_remove() Add a missing resource clean up in .remove.
Affected products
- Linux kernel: from 6.1 before 6.1.21; from 6.2 before 6.2.8; 6.3-rc1, 6.3-rc2 — fixed in 6.1.21, 6.2.8
How to fix
Upgrade to a fixed version: Linux kernel 6.1.21, 6.2.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0023972a7593720f8878aed06c03ac9e541078be
- https://git.kernel.org/stable/c/ce756daa36e1ba271bb3334267295e447aa57a5c
- https://git.kernel.org/stable/c/cf9777be5683c5e55680c089df02ee27d2226aa8
Get alerted when CVE-2023-53127 or the next vulnerability affects your stack