What’s Vulnerable › Vulnerabilities
CVE-2023-53156
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-27 · updated 2026-06-17
- Weakness: CWE-190
Description
The transpose crate before 0.2.3 for Rust allows an integer overflow via input_width and input_height arguments.
Affected products
- ejmahler transpose: from 0.1.0 before 0.2.3 — fixed in 0.2.3
How to fix
Upgrade to a fixed version: ejmahler transpose 0.2.3. Check the vendor advisory for mitigations.
References
- https://crates.io/crates/transpose
- https://github.com/advisories/GHSA-5gmm-6m36-r7jh
- https://github.com/ejmahler/transpose/issues/11
- https://rustsec.org/advisories/RUSTSEC-2023-0080.html
Get alerted when CVE-2023-53156 or the next vulnerability affects your stack