What’s Vulnerable › Vulnerabilities
CVE-2023-53157
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-130
Description
The rosenpass crate before 0.2.1 for Rust allows remote attackers to cause a denial of service (panic) via a one-byte UDP packet.
Affected products
- rosenpass: before 0.2.1 — fixed in 0.2.1
How to fix
Upgrade to a fixed version: rosenpass 0.2.1. Check the vendor advisory for mitigations.
References
- https://crates.io/crates/rosenpass
- https://github.com/advisories/GHSA-6ggr-cwv4-g7qg
- https://github.com/rosenpass/rosenpass/commit/93439858d1c44294a7b377f775c4fc897a370bb2
- https://rustsec.org/advisories/RUSTSEC-2023-0077.html
Get alerted when CVE-2023-53157 or the next vulnerability affects your stack