What’s Vulnerable › Vulnerabilities
CVE-2023-53161
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-125
Description
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
Affected products
- sequoia-pgp buffered-reader: before 1.0.2; from 1.1.0 before 1.1.5 — fixed in 1.0.2, 1.1.5
How to fix
Upgrade to a fixed version: sequoia-pgp buffered-reader 1.0.2, 1.1.5. Check the vendor advisory for mitigations.
References
- https://crates.io/crates/buffered-reader
- https://github.com/advisories/GHSA-29mf-62xx-28jq
- https://gitlab.com/sequoia-pgp/sequoia/-/tags/buffered-reader%2Fv1.0.2
- https://gitlab.com/sequoia-pgp/sequoia/-/tags/buffered-reader%2Fv1.1.5
- https://lists.sequoia-pgp.org/hyperkitty/list/announce@lists.sequoia-pgp.org/thread/SN2E3QRT4DMQ5JNEK6VIN6DJ5SH766DI/
- https://rustsec.org/advisories/RUSTSEC-2023-0039.html
Get alerted when CVE-2023-53161 or the next vulnerability affects your stack